Widescreen Gaming Forum

[-noun] Web community dedicated to ensuring PC games run properly on your tablet, netbook, personal computer, HDTV and multi-monitor gaming rig.
Last visit was: less than a minute ago It is currently 06 Feb 2023, 07:59

All times are UTC [ DST ]

 [ 1 post ] 
Author Message
PostPosted: 30 Dec 2018, 01:10 
User avatar

Joined: 11 Oct 2018, 16:17
Posts: 7
Greetings, I would like to start by apologizing if this is the wrong place for this or if I did something wrong. I haven't been around long enough.

The issue is, back in March this year AC IV received an update (apparently), I tried looking for more info but all I got was that it was released to add Chinese language support to the game.
Normally I lock my games via different methods so they don't automatically update every time I log in into... Steam, Uplay, Origin, etc. But I had some issues with my RIG a few days ago and I must've forgot to place everything back in it's place.
Long story short, the game updated, over-writing the 21:9 executable that I gotten here a while back, so I went ahead and got it again, but apparently the executables are very different now, between updates, and the game crashes... a lot, in many different places, if trying to run it with the old modified executable.
Now, personally I have no need for the Chinese language update and I would gladly revert back to the previous version except... I can't, have been unable to find the files or a way. Also I figured it would be difficult to play online with an old update.

I have some basic idea on how to use a HEX editor and I did manage to get the old executable from someone who was kind enough to share it with me, and then I tried comparing the files to see if I could figure out the modification performed and be able to replicate it on the new executable but no such luck, there is way too many differences between the files (maybe I got the wrong old version of the executable?).


After the March update the 21:9 modified executable doesn't work properly anymore and my (noobie) efforts to fix it did no good. If someone is able to help me somehow or has some insight, it would be much appreciated. I'm attaching my current, updated, unmodified executable in case it can be of help. Let me know if I can provide more information or anything.

pS: The executable is compressed and split into 2 parts (because of file size limitations). Also the extensions are changed on both files (because 001,002,etc upload is not allowed) so rename from "AC4BFSP.7z.001.7z" to just "AC4BFSP.7z.001" for both files before decompressing.

You do not have the required permissions to view the files attached to this post.


 [ 1 post ] 

All times are UTC [ DST ]

Who is online

Users browsing this forum: Ahrefs [Bot], CommonCrawl [Bot] and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  

Powered by phpBB® Forum Software © phpBB Group