Widescreen Gaming Forum

[-noun] Web community dedicated to ensuring PC games run properly on your tablet, netbook, personal computer, HDTV and multi-monitor gaming rig.
Last visit was: less than a minute ago It is currently 08 Aug 2020, 13:04

All times are UTC [ DST ]




 [ 7 posts ] 
Author Message
PostPosted: 18 Nov 2014, 17:57 
Offline

Joined: 29 Oct 2014, 15:46
Posts: 9
I picked up my new PC on Friday, with three GTX 980s and three new monitors, and proceeded to get everything wired up at home including Display Port cables for the monitors.

When it finally came time to push the switches and fire it up, I found that the middle monitor would not display an image though it was display the monitor's boot-up screen. I went about debugging it with different cables, plugging into different DP ports on the cards and different cards none of which worked. One thing I did do that worked was I used an HDMI cable so at least I verified the monitor in question wasn't totally FUBAR.

At this point I called the place the put the system together for me and set up an appointment for them to come to my house on Saturday to test things out with a different PC and cable. When they tried their PC with a DP cable they brought the 2nd monitor worked so I just plugged into my PC and it still worked. The problem appear to be solved but my gut told me that was too simple.

Fast forward to later that day and I decided to calibrate my monitors. The 2nd one's color looked a bit off so I decided to check its settings against another of monitor. When I started to access menu setting on the two monitors they suddenly stopped working. At this point my patience was wearing thin and since they were closed I couldn't call the store. That lead me to start doing my own research and I found that DP support for the 980s is unreliable at best. The latest drivers don't resolve the issues either so I went out and bought three HDMI cables and it's worked perfect for 3 days now.


Top
  
 


PostPosted: 18 Nov 2014, 21:00 
Offline
Editors
Editors
User avatar

Joined: 08 May 2011, 18:58
Posts: 2286
What Monitor do you have?

_________________
We gonna send it to outa space!


Top
  
 
PostPosted: 18 Nov 2014, 21:25 
Offline

Joined: 29 Oct 2014, 15:46
Posts: 9
Haldi wrote:
What Monitor do you have?
BenQ GW2765HT.


Top
  
 
PostPosted: 19 Nov 2014, 11:51 
Offline
Insiders
Insiders
User avatar

Joined: 14 Apr 2007, 02:13
Posts: 1514
I'm running three monitors using DisplayPort on a single GTX980 and it's been flawless.

_________________
Widescreen Fixer - https://www.widescreenfixer.org/

Widescreen Fixer Twitter - https://twitter.com/widescreenfixer
Personal Twitter - https://twitter.com/davidrudie


Top
  
 
PostPosted: 19 Nov 2014, 17:24 
Offline

Joined: 29 Oct 2014, 15:46
Posts: 9
dopefish wrote:
I'm running three monitors using DisplayPort on a single GTX980 and it's been flawless.
That's just the luck of the draw. Some folks have had no issues with their GTX980s whereas others have.

In one of the posts I read on this topic some hypothesized that certain DisplayPort cables have the 20th pin wired up which send +3.3V back to the card and that causes it to freak out and not work reliably or at all. That might be true but I didn't feel like messing around with that so opted for the HDMI solution.


Top
  
 
PostPosted: 19 Nov 2014, 19:22 
Offline
Editors
Editors
User avatar

Joined: 08 May 2011, 18:58
Posts: 2286
Matt_B wrote:
In one of the posts I read on this topic some hypothesized that certain DisplayPort cables have the 20th pin wired up which send +3.3V back to the card and that causes it to freak out and not work reliably or at all. That might be true but I didn't feel like messing around with that so opted for the HDMI solution.


That was also a huge Problem on AMD cards at the early DP days.
Haven't heard much of it lately.

That's why I asked about the Monitor! Maybe Nvidia drivers don't yet recognize all Monitors over DP.

_________________
We gonna send it to outa space!


Top
  
 
PostPosted: 19 Nov 2014, 19:32 
Offline

Joined: 29 Oct 2014, 15:46
Posts: 9
Haldi wrote:
Matt_B wrote:
In one of the posts I read on this topic some hypothesized that certain DisplayPort cables have the 20th pin wired up which send +3.3V back to the card and that causes it to freak out and not work reliably or at all. That might be true but I didn't feel like messing around with that so opted for the HDMI solution.


That was also a huge Problem on AMD cards at the early DP days.
Haven't heard much of it lately.

That's why I asked about the Monitor! Maybe Nvidia drivers don't yet recognize all Monitors over DP.
Yeah my issues could be a result of my specific monitors and the card. I don't recall seeing any pattern with other folks and their monitors but regardless, I'm good to go now.


Top
  
 
 [ 7 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  




Powered by phpBB® Forum Software © phpBB Group