Widescreen Gaming Forum

[-noun] Web community dedicated to ensuring PC games run properly on your tablet, netbook, personal computer, HDTV and multi-monitor gaming rig.
Last visit was: less than a minute ago It is currently 06 Jul 2020, 13:48

All times are UTC [ DST ]




 [ 2 posts ] 
Author Message
PostPosted: 28 Nov 2014, 13:45 
Offline

Joined: 31 Aug 2014, 20:07
Posts: 1
I've got a 3 monitor eyefinity display as follows:

1x Benq GL2460 - main monitor on the DVI-I port
1x Acer X223W on the HDMI port
1x Acer X223W on the MiniDisplay port (via an active adapter)

Windows 7

Gigabyte AMD Radeon HD 7870

The 3-display set-up was working fine until about a week ago, then it suddenly stopped working properly. I could still use Eyefinity to stretch it over the three displays but bezel correction doesn't work. Since I've been trying to sort out the problem I can now only display on 2 monitors.

The basic issue seems to be that Windows 7 doesn't seem to detect all of the monitors properly.

When I disconnect the MiniDisplay port two of the monitors are detected (the main Benq and the HDMI Acer). But when I reconnect the MiniDisplay it will still detect the Benq and one of the Acers but won't let me change resolution etc. on the detected Acer and won't display on either of the Acers.

When I disconnect the HDMI port Win 7 detects all three monitors (even though the HDMI Acer isn't connected), but when I reconnect the HDMI it goes back to only detecting two monitors as before.

I thought it might be the active adapter on the minidisplay port that had stopped working (it was a generic one for Apple devices). But I've just installed a pc-specific adaptive adapter and get the same problem.

All three monitors were working fine until a week or so ago and I can't figure out what's wrong. The only thing changed prior to the problem was updating the Origin game launcher program (but can't see why that would affect anything).

Any advice?


Top
  
 


PostPosted: 03 Dec 2014, 01:59 
Offline

Joined: 03 Dec 2014, 01:26
Posts: 3
hello

if it's a software problem, restoring windows to a previous state may resolve your problem. (ie before you updated origin)
windows -> run -> rstrui.exe

did you tried to temporally desactivate all softwares automatically lauched at the startup of your computer ? (windows -> run -> msconfig -> 4th tab on windows 7)

if it's a faulty hardware problem, to verify it you can swap monitors and adapters


Top
  
 
 [ 2 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  




Powered by phpBB® Forum Software © phpBB Group