Widescreen Gaming Forum

[-noun] Web community dedicated to ensuring PC games run properly on your tablet, netbook, personal computer, HDTV and multi-monitor gaming rig.
Last visit was: less than a minute ago It is currently 31 May 2020, 13:19

All times are UTC [ DST ]




 [ 3 posts ] 
Author Message
PostPosted: 18 Nov 2016, 12:48 
Offline
I Donated
I Donated

Joined: 18 Jul 2007, 04:19
Posts: 513
I can play all games at High settings running NV surround at around 45-50 FPS. Solid 60+ when at 4320x900.

However when playing this game at 4320x900 in Universe (Crusader) at LOW settings, I can't get higher than 25 FPS. This is ridiculous, since I not only always get solid framerate when playing at resolutions lower than 5760x1200, especially when graphics settings are at the lowest.

Is the FPS related to just Universe mode? Is it SLI related as well?...Does the game need an to implement SLI via a patch even though it's already got a working profile?

I've had weird issues as well where even if I play the game at 1920x1080 at LOW the FPS is still 25. I had ONE instance where it ran the game at 45-50 FPS in Universe ONCE at 1080p, then couldn't do it again.

Are there any fixes to this?! There has to be some way to get more FPS in Universe at the lowest settings!


Top
  
 


PostPosted: 20 Nov 2016, 00:17 
Offline
Editors
Editors
User avatar

Joined: 08 May 2011, 18:58
Posts: 2286
It's an issue with the Netcode.
The game is still loading all assets even if not visible (or did they fix that now?) So playing Multiplayer you will have bad FPS on all systems with all settings on all resolutions.

_________________
We gonna send it to outa space!


Top
  
 
PostPosted: 24 Apr 2017, 21:16 
Offline

Joined: 01 Feb 2016, 17:44
Posts: 11
I get about an average 30 on low with a 970. (If the server is basically empty, that can go up to 40-60 briefly.) Note, that changing graphics settings to very high results in FPS drop of only a couple frames. 2-4, maybe. Seems to be CPU and server bottlenecked, atm. I rarely ever see full GPU utilization.


Top
  
 
 [ 3 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: CommonCrawl [Bot], DotNetDotCom.org [Bot] and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  




Powered by phpBB® Forum Software © phpBB Group