Widescreen Gaming Forum

[-noun] Web community dedicated to ensuring PC games run properly on your tablet, netbook, personal computer, HDTV and multi-monitor gaming rig.
Last visit was: less than a minute ago It is currently 25 Sep 2020, 04:17

All times are UTC [ DST ]




 [ 3 posts ] 
Author Message
PostPosted: 17 Jan 2017, 08:29 
Offline
User avatar

Joined: 16 Jan 2017, 09:47
Posts: 2
Firstly, hello to you all. :rockout:
I've been lurking the forums for years now and finally decided to sign up. Since I first built a triple screen gaming pc this forum has been the most helpful place for setting up and fixing games, so a big thank you to everyone for all that help. Special shout out to Haldi and HaYDeN for having the most helpful information that I've come across, especially with Bethesda games.

Now on to my issue: I have this weird bug where if I try to load up a game in windowed, borderless or triple full screen it limits itself to around 20fps +/- 5fps with both the gpu and cpu hardly even trying.
The main way to fix this is by changing the in game resolution to single full screen (16x9 ratio, any resolution) and then back again. After this the fps would jump back up to whatever the hardware is capable of pushing.
Some games though like Mass Effect, Just Cause and GTA V like to close and restart when you adjust the resolution which completely negates any benefit I get from this method.
So for games like this I'm left with only 1 alternative, a 2nd game running in the background.

I've found that any directX based game works for this so atm I use Antichamber, a lightweight UDK game running at 720p. If I load that one up, set it to fullscreen and then back to windowed I can minimise and ignore it and every other game I load up from there on runs just as it should without issue. If I were to close Antichamber though I'm back at the ~20fps cap again.

While the workaround is currently functioning, it's annoying having to keep a game always running in the background and I'd like to fix the underlying issue.

For reference, here are my specs:
Asus Maximus VIII Gene
6600k @4.6
32GB GSkill DDR4
EVGA GTX1070 SC
3x 27" 1440p Korean monitors in surround mode
etc, I figure the rest doesn't matter

Any help would be greatly appreciated. :)
-
Cait


Top
  
 


PostPosted: 17 Jan 2017, 18:29 
Offline
Editors
Editors
User avatar

Joined: 08 May 2011, 18:58
Posts: 2286
Sup,
:welcome

Glad you finally took the jump and registered.


For strange issues like this a clean reset is always a good recommendation.
But because wiping windows is a pain you could try the Light method.
Have you heard of DDU? Display Driver Uninstaller? Completely removes GPU drivers and reinstall them afterwards.
MIGHT help.

Greetings,
Haldi

_________________
We gonna send it to outa space!


Top
  
 
PostPosted: 18 Jan 2017, 05:28 
Offline
User avatar

Joined: 16 Jan 2017, 09:47
Posts: 2
Funny enough that's the kind of thing I'd normally recommend to my friends who have issues like this yet didn't try it out myself

And yeah, sure enough, a clear out of drivers with DDU and updating from October's release to the latest (December) seems to have fixed it.
I'm not 100% confident though as I had many driver related issues with games not running right a few months ago and the October one was the only recent version that worked, but so far so good.

I bet you if I tried this myself it would have failed, but because you suggested it, it worked :cheers:
Thanks again


Top
  
 
 [ 3 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  




Powered by phpBB® Forum Software © phpBB Group